What’s Vulnerable › Vulnerabilities

CVE-2025-5683

Description

When loading a specifically crafted ICNS format image file in QImage then it will trigger a crash.  This issue affects Qt from versions 6.3.0 through 6.5.9, from 6.6.0 through 6.8.4, 6.9.0. This is fixed in 6.5.10, 6.8.5 and 6.9.1.

Affected products

How to fix

Upgrade to a fixed version: Qt 6.5.10, 6.8.5, 6.9.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-5683 or the next vulnerability affects your stack