What’s Vulnerable › Vulnerabilities
CVE-2025-5687: Local privilege escalation vulnerability in Mozilla VPN clients for macOS v2.27.0 and below.
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-11 · updated 2026-06-17
- Weakness: CWE-269
Description
A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root. *This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).
Affected products
- Mozilla VPN 2.16.1: before 2.28.0 — fixed in 2.28.0
How to fix
Upgrade to a fixed version: Mozilla VPN 2.16.1 2.28.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1953736
- https://www.mozilla.org/security/advisories/mfsa2025-48/
Get alerted when CVE-2025-5687 or the next vulnerability affects your stack