What’s Vulnerable › Vulnerabilities
CVE-2025-5689: Improper Permission Management in SSH Session Handling
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-16 · updated 2026-06-17
- Weakness: CWE-269
Description
A flaw was found in the temporary user record that authd uses in the pre-auth NSS. As a result, a user login for the first time will be considered to be part of the root group in the context of that SSH session.
Affected products
- Canonical authd: before 0.5.4 — fixed in 0.5.4
How to fix
Upgrade to a fixed version: Canonical authd 0.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-5689 or the next vulnerability affects your stack