What’s Vulnerable › Vulnerabilities
CVE-2025-5690: Cursor allows PostgreSQL Anonymizer masked user to gain unauthorized access to authentic data
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-200
Description
PostgreSQL Anonymizer v2.0 and v2.1 contain a vulnerability that allows a masked user to bypass the masking rules defined on a table and read the original data using a database cursor or the --insert option of pg_dump. This problem occurs only when dynamic masking is enabled, which is not the default setting. The problem is resolved in version 2.2.1
Affected products
- DALIBO PostgreSQL Anonymizer: from 1 before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: DALIBO PostgreSQL Anonymizer 2.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-5690 or the next vulnerability affects your stack