What’s Vulnerable › Vulnerabilities
CVE-2025-57348
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-24 · updated 2026-06-17
- Weakness: CWE-1321
Description
The node-cube package (prior to version 5.0.0) contains a vulnerability in its handling of prototype chain initialization, which could allow an attacker to inject properties into the prototype of built-in objects. This issue, categorized under CWE-1321, arises from improper validation of user-supplied input in the package's resource initialization process. Successful exploitation may lead to denial of service or arbitrary code execution in affected environments. The vulnerability affects versions up to and including 5.0.0-beta.19, and no official fix has been released to date.
Affected products
- Node-Cube: before 5.0.0; 5.0.0-beta0, 5.0.0-beta1, 5.0.0-beta10, 5.0.0-beta11, 5.0.0-beta12, 5.0.0-beta13 (+13) — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Node-Cube 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/VulnSageAgent/PoCs/tree/main/JavaScript/prototype-pollution/CVE-2025-57348
- https://github.com/node-cube/cube/issues/153
Get alerted when CVE-2025-57348 or the next vulnerability affects your stack