What’s Vulnerable › Vulnerabilities
CVE-2025-57729
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-20 · updated 2026-06-17
- Weakness: CWE-829
Description
In JetBrains IntelliJ IDEA before 2025.2 unexpected plugin startup was possible due to automatic LSP server start
Affected products
- JetBrains IntelliJ IDEA: before 2025.2 — fixed in 2025.2
How to fix
Upgrade to a fixed version: JetBrains IntelliJ IDEA 2025.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-57729 or the next vulnerability affects your stack