What’s Vulnerable › Vulnerabilities

CVE-2025-57740

Description

An Heap-based Buffer Overflow vulnerability [CWE-122] in FortiOS version 7.6.2 and below, version 7.4.7 and below, version 7.2.10 and below, 7.0 all versions, 6.4 all versions; FortiPAM version 1.5.0, version 1.4.2 and below, 1.3 all versions, 1.2 all versions, 1.1 all versions, 1.0 all versions and FortiProxy version 7.6.2 and below, version 7.4.3 and below, 7.2 all versions, 7.0 all versions RDP bookmark connection may allow an authenticated user to execute unauthorized code via crafted requests.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.2.11, 7.4.8, 7.6.3; Fortinet FortiPAM 1.4.3; Fortinet FortiProxy 7.4.4, 7.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-57740 or the next vulnerability affects your stack