What’s Vulnerable › Vulnerabilities
CVE-2025-57752: Next.js Affected by Cache Key Confusion for Image Optimization API Routes
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-18
- Weakness: CWE-524
Description
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization API routes are affected by cache key confusion. When images returned from API routes vary based on request headers (such as Cookie or Authorization), these responses could be incorrectly cached and served to unauthorized users due to a cache key confusion bug. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5. All users are encouraged to upgrade if they use API routes to serve images that depend on request headers and have image optimization enabled.
Affected products
- Next.js: before 14.2.31; from 15.0.0 before 15.4.5 — fixed in 14.2.31, 15.4.5
- Npm Next: from 0.9.9 before 14.2.31; from 15.0.0 before 15.4.5 — fixed in 14.2.31, 15.4.5
How to fix
Upgrade to a fixed version: Next.js 14.2.31, 15.4.5; Npm Next 14.2.31, 15.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/6b12c60c61ee80cb0443ccd20de82ca9b4422ddd
- https://github.com/vercel/next.js/pull/82114
- https://github.com/vercel/next.js/security/advisories/GHSA-g5qg-72qw-gw5v
- https://vercel.com/changelog/cve-2025-57752
Get alerted when CVE-2025-57752 or the next vulnerability affects your stack