What’s Vulnerable › Vulnerabilities
CVE-2025-57758: Contao has improper access control in the back end voters
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-28 · updated 2026-06-17
- Weakness: CWE-284
Description
Contao is an Open Source CMS. In versions starting from 5.0.0 and prior to 5.3.38 and 5.6.1, the table access voter in the back end doesn't check if a user is allowed to access the corresponding module. This issue has been patched in versions 5.3.38 and 5.6.1. A workaround involves not relying solely on the voter and additionally to check USER_CAN_ACCESS_MODULE.
Affected products
- contao: from 5.3.0 before 5.3.38; from 5.4.0 before 5.6.1 — fixed in 5.3.38, 5.6.1
How to fix
Upgrade to a fixed version: contao 5.3.38, 5.6.1. Check the vendor advisory for mitigations.
References
- https://contao.org/en/security-advisories/improper-access-control-in-the-back-end-voters
- https://github.com/contao/contao/commit/3f05c603e1c94d34819f837f060df5d66447d0d7
- https://github.com/contao/contao/security/advisories/GHSA-7m47-r75r-cx8v
Get alerted when CVE-2025-57758 or the next vulnerability affects your stack