What’s Vulnerable › Vulnerabilities
CVE-2025-57760: Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-25 · updated 2026-06-17
- Weakness: CWE-269
Description
Langflow is a tool for building and deploying AI-powered agents and workflows. A privilege escalation vulnerability exists in Langflow containers where an authenticated user with RCE access can invoke the internal CLI command langflow superuser to create a new administrative user. This results in full superuser access, even if the user initially registered through the UI as a regular (non-admin) account. A patched version has not been made public at this time.
Affected products
- IBM Langflow OSS: before 1.5.0; 1.5.0-dev0, 1.5.0-dev1, 1.5.0-dev10, 1.5.0-dev11, 1.5.0-dev12, 1.5.0-dev13 (+26) — fixed in 1.5.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.5.0. Check the vendor advisory for mitigations.
References
- http://github.com/langflow-ai/langflow/pull/9152
- https://github.com/langflow-ai/langflow/commit/c188ec113c9ca46154ad01d0eded1754cc6bef97
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-4gv9-mp8m-592r
Get alerted when CVE-2025-57760 or the next vulnerability affects your stack