What’s Vulnerable › Vulnerabilities
CVE-2025-57767: Asterisk can crash from a specifically malformed Authorization header in an incoming SIP request
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-28 · updated 2026-06-17
- Weakness: CWE-253
Description
Asterisk is an open source private branch exchange and telephony toolkit. Prior to versions 20.15.2, 21.10.2, and 22.5.2, if a SIP request is received with an Authorization header that contains a realm that wasn't in a previous 401 response's WWW-Authenticate header, or an Authorization header with an incorrect realm was received without a previous 401 response being sent, the get_authorization_header() function in res_pjsip_authenticator_digest will return a NULL. This wasn't being checked before attempting to get the digest algorithm from the header which causes a SEGV. This issue has been patched in versions 20.15.2, 21.10.2, and 22.5.2. There are no workarounds.
Affected products
- asterisk: before 20.15.2; from 21.0.0 before 21.10.2; from 22.0.0 before 22.5.2 — fixed in 20.15.2, 21.10.2, 22.5.2
How to fix
Upgrade to a fixed version: asterisk 20.15.2, 21.10.2, 22.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/asterisk/asterisk/commit/02993717b08f899d4aca9888062f35dfb198584f
- https://github.com/asterisk/asterisk/pull/1407
- https://github.com/asterisk/asterisk/security/advisories/GHSA-64qc-9x89-rx5j
Get alerted when CVE-2025-57767 or the next vulnerability affects your stack