What’s Vulnerable › Vulnerabilities
CVE-2025-57773: Dataease DB2 Aspectweaver Deserialization Arbitrary File Write Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-25 · updated 2026-06-17
- Weakness: CWE-94
Description
DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.12, because DB2 parameters are not filtered, a JNDI injection attack can be directly launched. JNDI triggers an AspectJWeaver deserialization attack, writing to various files. This vulnerability requires commons-collections 4.x and aspectjweaver-1.9.22.jar. The vulnerability has been fixed in version 2.10.12.
Affected products
- dataease: before 2.10.12 — fixed in 2.10.12
How to fix
Upgrade to a fixed version: dataease 2.10.12. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/8d04e92d44e1bac9284e9e64df5afd7f96d9373c
- https://github.com/dataease/dataease/security/advisories/GHSA-7r8j-6whv-4j5p
Get alerted when CVE-2025-57773 or the next vulnerability affects your stack