What’s Vulnerable › Vulnerabilities
CVE-2025-57811: Craft Potential Remote Code Execution via Twig SSTI
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-25 · updated 2026-06-17
- Weakness: CWE-1336
Description
Craft is a platform for creating digital experiences. From versions 4.0.0-RC1 to 4.16.5 and 5.0.0-RC1 to 5.8.6, there is a potential remote code execution vulnerability via Twig SSTI (Server-Side Template Injection). This is a follow-up to CVE-2024-52293. This vulnerability has been patched in versions 4.16.6 and 5.8.7.
Affected products
- craftcms cms: from 4.1.0 before 4.16.6; from 5.1.0 before 5.8.7; 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 5.0.0-rc1 — fixed in 4.16.6, 5.8.7
How to fix
Upgrade to a fixed version: craftcms cms 4.16.6, 5.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/e77f8a287dcdda41f1724f525d03542f18566cbc
- https://github.com/craftcms/cms/pull/17612
- https://github.com/craftcms/cms/security/advisories/GHSA-crcq-738g-pqvc
Get alerted when CVE-2025-57811 or the next vulnerability affects your stack