What’s Vulnerable › Vulnerabilities
CVE-2025-57815: Fides Lacks Brute-Force Protections on Authentication Endpoints
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-08 · updated 2026-06-17
- Weakness: CWE-307
Description
Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the Fides Admin UI login endpoint relies on a general IP-based rate limit for all API traffic and lacks specific anti-automation controls designed to protect against brute-force attacks. This could allow attackers to conduct credential testing attacks, such as credential stuffing or password spraying, which poses a risk to accounts with weak or previously compromised passwords. Version 2.69.1 fixes the issue. For organizations with commercial Fides Enterprise licenses, configuring Single Sign-On (SSO) through an OIDC provider (like Azure, Google, or Okta) is an effective workaround. When OIDC SSO is enabled, username/password authentication can be disabled entirely, which eliminates this attack vector. This functionality is not available for Fides Open Source users.
Affected products
- ethyca fides: before 2.69.1 — fixed in 2.69.1
How to fix
Upgrade to a fixed version: ethyca fides 2.69.1. Check the vendor advisory for mitigations.
References
- https://github.com/ethyca/fides/commit/59903c195e2f9f8915a1db94950aefd557033a5c
- https://github.com/ethyca/fides/releases/tag/2.69.1
- https://github.com/ethyca/fides/security/advisories/GHSA-7q62-r88r-j5gw
Get alerted when CVE-2025-57815 or the next vulnerability affects your stack