What’s Vulnerable › Vulnerabilities
CVE-2025-57817: Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-08 · updated 2026-06-17
- Weakness: CWE-862
Description
Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the OAuth client creation and update endpoints of the Fides Webserver API do not properly authorize scope assignment. This allows highly privileged users with `client:create` or `client:update` permissions to escalate their privileges to owner-level. Version 2.69.1 fixes the issue. No known workarounds are available.
Affected products
- ethyca fides: before 2.69.1 — fixed in 2.69.1
How to fix
Upgrade to a fixed version: ethyca fides 2.69.1. Check the vendor advisory for mitigations.
References
- https://github.com/ethyca/fides/commit/2ffd125e1089a09b84c27fb5279a05960cbf2452
- https://github.com/ethyca/fides/releases/tag/2.69.1
- https://github.com/ethyca/fides/security/advisories/GHSA-hjfh-p8f5-24wr
Get alerted when CVE-2025-57817 or the next vulnerability affects your stack