What’s Vulnerable › Vulnerabilities
CVE-2025-57819: Sangoma FreePBX Authentication Bypass Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-08-29
- EPSS: 95.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-28 · updated 2026-09-26
- Weakness: CWE-89
Description
FreePBX is an open-source web-based graphical user interface. FreePBX 15, 16, and 17 endpoints are vulnerable due to insufficiently sanitized user-supplied data allowing unauthenticated access to FreePBX Administrator leading to arbitrary database manipulation and remote code execution. This issue has been patched in endpoint versions 15.0.66, 16.0.89, and 17.0.3.
Affected products
- Sangoma FreePBX: from 15.0 before 15.0.66; from 16.0 before 16.0.89; from 17.0 before 17.0.3 — fixed in 15.0.66, 16.0.89, 17.0.3
How to fix
Upgrade to a fixed version: Sangoma FreePBX 15.0.66, 16.0.89, 17.0.3. Check the vendor advisory for mitigations.
References
- https://community.freepbx.org/t/security-advisory-please-lock-down-your-administrator-access/107203
- https://github.com/FreePBX/security-reporting/security/advisories/GHSA-m42g-xg4c-5f3h
- https://github.com/watchtowrlabs/watchTowr-vs-FreePBX-CVE-2025-57819
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-57819
Get alerted when CVE-2025-57819 or the next vulnerability affects your stack