What’s Vulnerable › Vulnerabilities
CVE-2025-57822: Next.js Improper Middleware Redirect Handling Leads to SSRF
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-29 · updated 2026-10-18
- Weakness: CWE-918
Description
Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.
Affected products
- Next.js: before 14.2.32; from 15.0.0 before 15.4.7 — fixed in 14.2.32, 15.4.7
- Npm Next: from 0.9.9 before 14.2.32; from 15.0.0-canary.0 before 15.4.7 — fixed in 14.2.32, 15.4.7
How to fix
Upgrade to a fixed version: Next.js 14.2.32, 15.4.7; Npm Next 14.2.32, 15.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/9c9aaed5bb9338ef31b0517ccf0ab4414f2093d8
- https://github.com/vercel/next.js/security/advisories/GHSA-4342-x723-ch2f
- https://vercel.com/changelog/cve-2025-57822
Get alerted when CVE-2025-57822 or the next vulnerability affects your stack