What’s Vulnerable › Vulnerabilities
CVE-2025-58046: Dataease has a JDBC attack vulnerability in the Impala datasource
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-15 · updated 2026-10-19
- Weakness: CWE-74
Description
Dataease is an open-source data visualization and analysis platform. In versions up to and including 2.10.12, the Impala data source is vulnerable to remote code execution due to insufficient filtering in the getJdbc method of the io.dataease.datasource.type.Impala class. Attackers can construct malicious JDBC connection strings that exploit JNDI injection and trigger RMI deserialization, ultimately enabling remote command execution. The vulnerability can be exploited by editing the data source and providing a crafted JDBC connection string that references a remote configuration file, leading to RMI-based deserialization attacks. This issue has been patched in version 2.10.13. It is recommended to upgrade to the latest version. No known workarounds exist for affected versions.
Affected products
- dataease: before 2.10.13 — fixed in 2.10.13
How to fix
Upgrade to a fixed version: dataease 2.10.13. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/8d04e92d44e1bac9284e9e64df5afd7f96d9373c
- https://github.com/dataease/dataease/security/advisories/GHSA-mvwc-x8x9-46c3
- https://github.com/dataease/dataease/security/advisories/GHSA-mvwc-x8x9-46c3
Get alerted when CVE-2025-58046 or the next vulnerability affects your stack