What’s Vulnerable › Vulnerabilities

CVE-2025-58054: Discourse is vulnerable to XSS when quoting chat messages

Description

Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.

Affected products

How to fix

Upgrade to a fixed version: discourse 3.5.0, 3.6.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-58054 or the next vulnerability affects your stack