What’s Vulnerable › Vulnerabilities
CVE-2025-58055: Discourse AI Suggestions Contain Insecure Direct Object Reference
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-01 · updated 2026-10-19
- Weakness: CWE-284
Description
Discourse is an open-source community discussion platform. In versions 3.5.0 and below, the Discourse AI suggestion endpoints for topic “Title”, “Category”, and “Tags” allowed authenticated users to extract information about topics that they weren’t authorized to access. By modifying the “topic_id” value in API requests to the AI suggestion endpoints, users could target specific restricted topics. The AI model’s responses then disclosed information that the authenticated user couldn’t normally access. This issue is fixed in version 3.5.1. To workaround this issue, users can restrict group access to the AI helper feature through the "composer_ai_helper_allowed_groups" and "post_ai_helper_allowed_groups" site settings.
Affected products
- discourse: before 3.5.1; before 3.6.0; 3.6.0-beta1 — fixed in 3.5.1, 3.6.0
How to fix
Upgrade to a fixed version: discourse 3.5.1, 3.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/28d569cae9b33cd55d647bf41806106e33d975c9
- https://github.com/discourse/discourse/security/advisories/GHSA-32v2-x274-vfhr
- https://www.vicarius.io/vsociety/posts/cve-2025-58055-detect-discourse-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-58055-mitigate-discourse-vulnerability
Get alerted when CVE-2025-58055 or the next vulnerability affects your stack