What’s Vulnerable › Vulnerabilities
CVE-2025-58057: Netty's BrotliDecoder is vulnerable to DoS via zip bomb style attack
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-04 · updated 2026-10-19
- Weakness: CWE-409
Description
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.
Affected products
- netty: before 4.1.125; from 4.2.0 before 4.2.5 — fixed in 4.1.125, 4.2.5
How to fix
Upgrade to a fixed version: netty 4.1.125, 4.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/commit/9d804c54ce962408ae6418255a83a13924f7145d
- https://github.com/netty/netty/security/advisories/GHSA-3p8m-j85q-pgmj
Get alerted when CVE-2025-58057 or the next vulnerability affects your stack