What’s Vulnerable › Vulnerabilities
CVE-2025-58060: cups has Authentication bypass with AuthType Negotiate
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-11 · updated 2026-06-17
- Weakness: CWE-287
Description
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, when the `AuthType` is set to anything but `Basic`, if the request contains an `Authorization: Basic ...` header, the password is not checked. This results in authentication bypass. Any configuration that allows an `AuthType` that is not `Basic` is affected. Version 2.4.13 fixes the issue.
Affected products
- OpenPrinting cups: before 2.4.13 — fixed in 2.4.13
How to fix
Upgrade to a fixed version: OpenPrinting cups 2.4.13. Check the vendor advisory for mitigations.
References
- https://github.com/OpenPrinting/cups/commit/595d691075b1d396d2edfaa0a8fd0873a0a1f221
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-4c68-qgrh-rmmq
- http://www.openwall.com/lists/oss-security/2025/09/11/1
- https://lists.debian.org/debian-lts-announce/2025/09/msg00013.html
Get alerted when CVE-2025-58060 or the next vulnerability affects your stack