What’s Vulnerable › Vulnerabilities
CVE-2025-58062: LSTM-Kirigaya's openmcp-client Vulnerable to RCE in MCP Authorization Flow
- Severity: high (CVSS 7.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-28 · updated 2026-06-17
- Weakness: CWE-78
Description
LSTM-Kirigaya's openmcp-client is a vscode plugin for mcp developer. Prior to version 0.1.12, when users on a Windows platform connect to an attacker controlled MCP server, attackers could provision a malicious authorization server endpoint to silently achieve an OS command injection attack in the open() invocation, leading to client system compromise. This issue has been patched in version 0.1.12.
Affected products
- LSTM-Kirigaya openmcp-client: before 0.1.12
References
- https://drive.google.com/file/d/1lSqFkc412aX6a_fjmNfzXsJKE7b8jPqD/view?usp=sharing
- https://github.com/LSTM-Kirigaya/openmcp-client/commit/9c3799d6ffae8d0cdfab25a53af75e1afc85f6c3
- https://github.com/LSTM-Kirigaya/openmcp-client/security/advisories/GHSA-43m4-p3rv-c4v8
Get alerted when CVE-2025-58062 or the next vulnerability affects your stack