What’s Vulnerable › Vulnerabilities
CVE-2025-58065: Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-11 · updated 2026-06-17
- Weakness: CWE-287
Description
Flask-AppBuilder is an application development framework. Prior to version 4.8.1, when Flask-AppBuilder is configured to use OAuth, LDAP, or other non-database authentication methods, the password reset endpoint remains registered and accessible, despite not being displayed in the user interface. This allows an enabled user to reset their password and be able to create JWT tokens even after the user is disabled on the authentication provider. Users should upgrade to Flask-AppBuilder version 4.8.1 or later to receive a fix. If immediate upgrade is not possible, manually disable password reset routes in the application configuration; implement additional access controls at the web server or proxy level to block access to the reset my password URL; and/or monitor for suspicious password reset attempts from disabled accounts.
Affected products
- dpgaspar Flask-AppBuilder: before 4.8.1 — fixed in 4.8.1
How to fix
Upgrade to a fixed version: dpgaspar Flask-AppBuilder 4.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/dpgaspar/Flask-AppBuilder/commit/a942a9cc5775752f9a02f97fd8198dd288fa93ee
- https://github.com/dpgaspar/Flask-AppBuilder/pull/2384
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v4.8.1
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-765j-9r45-w2q2
Get alerted when CVE-2025-58065 or the next vulnerability affects your stack