What’s Vulnerable › Vulnerabilities
CVE-2025-58066: DoS Vulnerability in ntpd-rs
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-18
- Weakness: CWE-406
Description
nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.
Affected products
- pendulum-project ntpd-rs: from 1.2.0, < 1.6.2
References
- https://github.com/pendulum-project/ntpd-rs/commit/da37cf167736cbd4d7804b1ed7ceb572468298e0
- https://github.com/pendulum-project/ntpd-rs/security/advisories/GHSA-4855-q42w-5vr4
Get alerted when CVE-2025-58066 or the next vulnerability affects your stack