What’s Vulnerable › Vulnerabilities
CVE-2025-58068: Eventlet affected by HTTP request smuggling in unparsed trailers
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-19
- Weakness: CWE-444
Description
Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.
Affected products
- eventlet: before 0.40.3 — fixed in 0.40.3
How to fix
Upgrade to a fixed version: eventlet 0.40.3. Check the vendor advisory for mitigations.
References
- https://github.com/eventlet/eventlet/commit/0bfebd1117d392559e25b4bfbfcc941754de88fb
- https://github.com/eventlet/eventlet/pull/1062
- https://github.com/eventlet/eventlet/security/advisories/GHSA-hw6f-rjfj-j7j7
- https://lists.debian.org/debian-lts-announce/2025/09/msg00003.html
Get alerted when CVE-2025-58068 or the next vulnerability affects your stack