What’s Vulnerable › Vulnerabilities
CVE-2025-58098: Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-09-25
- Weakness: CWE-201
Description
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Affected products
- Apache HTTP Server: before 2.4.66 — fixed in 2.4.66
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.66. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2025/12/04/5
Get alerted when CVE-2025-58098 or the next vulnerability affects your stack