What’s Vulnerable › Vulnerabilities
CVE-2025-58121: Insufficient permission validation on multiple REST API endpoints
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-18 · updated 2026-10-19
- Weakness: CWE-280
Description
Insufficient permission validation on multiple REST API endpoints in Checkmk 2.2.0, 2.3.0, and 2.4.0 before version 2.4.0p16 allows low-privileged users to perform unauthorized actions or obtain sensitive information
Affected products
- Checkmk GmbH Checkmk: from 2.2.0 before 2.4.0; 2.4.0, 2.4.0-b1, 2.4.0-b2, 2.4.0-b3, 2.4.0-b4, 2.4.0-b5 (+16) — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Checkmk GmbH Checkmk 2.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-58121 or the next vulnerability affects your stack