What’s Vulnerable › Vulnerabilities
CVE-2025-58130: Apache Fineract: Server Key not masked
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-12 · updated 2026-10-07
- Weakness: CWE-522
Description
Insufficiently Protected Credentials vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1. Users are encouraged to upgrade to version 1.13.0, the latest release.
Affected products
- Apache Software Foundation Apache Fineract: before 1.12.1 — fixed in 1.12.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fineract 1.12.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/d9zpkc86zk265523tfvbr8w7gyr6onoy
- http://www.openwall.com/lists/oss-security/2025/12/11/6
Get alerted when CVE-2025-58130 or the next vulnerability affects your stack