What’s Vulnerable › Vulnerabilities

CVE-2025-58136: Apache Traffic Server: A simple legitimate POST request causes a crash

Description

A bug in POST request handling causes a crash under a certain condition. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.1, from 9.0.0 through 9.2.12. Users are recommended to upgrade to version 10.1.2 or 9.2.13, which fix the issue. A workaround for older versions is to set proxy.config.http.request_buffer_enabled to 0 (the default value is 0).

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 10.1.2, 9.2.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-58136 or the next vulnerability affects your stack