What’s Vulnerable › Vulnerabilities
CVE-2025-58137: Apache Fineract: IDOR via self-service API
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-12 · updated 2026-10-07
- Weakness: CWE-639
Description
Authorization Bypass Through User-Controlled Key vulnerability in Apache Fineract. This issue affects Apache Fineract: through 1.11.0. The issue is fixed in version 1.12.1. Users are encouraged to upgrade to version 1.13.0, the latest release.
Affected products
- Apache Software Foundation Apache Fineract: before 1.12.1 — fixed in 1.12.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fineract 1.12.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/gz3zhoghlclch3rdnzyrdcf69c0507ww
- http://www.openwall.com/lists/oss-security/2025/12/11/7
Get alerted when CVE-2025-58137 or the next vulnerability affects your stack