What’s Vulnerable › Vulnerabilities
CVE-2025-58173: FreshRSS vulnerable to authenticated RCE via path traversal inside include()
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-16 · updated 2026-10-14
- Weakness: CWE-20
Description
FreshRSS is a self-hosted RSS feed aggregator. In versions 1.23.0 through 1.27.0, using a path traversal inside the `language` user configuration parameter, it's possible to call `install.php` and perform various administrative actions as an unprivileged user. These actions include logging in as the admin, creating a new admin user, or set the database to an attacker-controlled MySQL server and abuse it to execute code in FreshRSS by setting malicious feed `curl_params` inside the `feed` table. Version 1.27.1 fixes the issue.
Affected products
- FreshRSS: from 1.23.0 before 1.27.1 — fixed in 1.27.1
How to fix
Upgrade to a fixed version: FreshRSS 1.27.1. Check the vendor advisory for mitigations.
References
- https://github.com/FreshRSS/FreshRSS/commit/79604aa4b3051f083d1734bd9e82c6a89d785c5a#diff-49280171b6e7964e21a0270427e56eacb47b8ac562593a01ad4bc74b49f840c7R135
- https://github.com/FreshRSS/FreshRSS/commit/dbbae15a8458679db0f4540dacdbdcff9c02ec8c#diff-63f610c36d0f2555c1787f6d0804f46f4df6e0f918dfe03408309039abf6efebL85-L88
- https://github.com/FreshRSS/FreshRSS/commit/ee175dd6169a016fc898fac62d046e22c205dec0#diff-6ebff7743ede829cf5a7f0e4566b42023a2d4779cc8d7e96fefec116f2292174R190-R194
- https://github.com/FreshRSS/FreshRSS/pull/7878
- https://github.com/FreshRSS/FreshRSS/pull/7971
- https://github.com/FreshRSS/FreshRSS/pull/7979
- https://github.com/FreshRSS/FreshRSS/security/advisories/GHSA-6c8h-w3j5-j293
- https://github.com/FreshRSS/FreshRSS/security/advisories/GHSA-6c8h-w3j5-j293
Get alerted when CVE-2025-58173 or the next vulnerability affects your stack