What’s Vulnerable › Vulnerabilities
CVE-2025-58179: Astro Cloudflare adapter is vulnerable to Server-Side Request Forgery via /_image endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-05 · updated 2026-06-17
- Weakness: CWE-918
Description
Astro is a web framework for content-driven websites. Versions 11.0.3 through 12.6.5 are vulnerable to SSRF when using Astro's Cloudflare adapter. When configured with output: 'server' while using the default imageService: 'compile', the generated image optimization endpoint doesn't check the URLs it receives, allowing content from unauthorized third-party domains to be served. a A bug in impacted versions of the @astrojs/cloudflare adapter for deployment on Cloudflare’s infrastructure, allows an attacker to bypass the third-party domain restrictions and serve any content from the vulnerable origin. This issue is fixed in version 12.6.6.
Affected products
- Astro @Astrojs/Cloudflare: from 11.0.3 before 12.6.6 — fixed in 12.6.6
How to fix
Upgrade to a fixed version: Astro @Astrojs/Cloudflare 12.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/withastro/astro/commit/9ecf3598e2b29dd74614328fde3047ea90e67252
- https://github.com/withastro/astro/security/advisories/GHSA-qpr4-c339-7vq8
Get alerted when CVE-2025-58179 or the next vulnerability affects your stack