What’s Vulnerable › Vulnerabilities
CVE-2025-58334
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-28 · updated 2026-09-26
- Weakness: CWE-862
Description
In JetBrains IDE Services before 2025.5.0.1086, 2025.4.2.2164 users without appropriate permissions could assign high-privileged role for themselves
Affected products
- JetBrains IDE Services: before 2025.4.2.2164; from 2025.5 before 2025.5.0.1086 — fixed in 2025.4.2.2164, 2025.5.0.1086
How to fix
Upgrade to a fixed version: JetBrains IDE Services 2025.4.2.2164, 2025.5.0.1086. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-58334 or the next vulnerability affects your stack