What’s Vulnerable › Vulnerabilities
CVE-2025-58358: Markdownify is vulnerable to command injection through pptx-to-markdown tool
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-06-17
- Weakness: CWE-77
Description
Markdownify is a Model Context Protocol server for converting almost anything to Markdown. Versions below 0.0.2 contain a command injection vulnerability, caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). This issue is fixed in version 0.0.2.
Affected products
- zcaceres markdownify-mcp: before 0.0.2
References
- https://github.com/zcaceres/markdownify-mcp/commit/a31204de058b22a47e1dcc24508993cfe97e5bb3
- https://github.com/zcaceres/markdownify-mcp/security/advisories/GHSA-45qj-4xq3-3c45
Get alerted when CVE-2025-58358 or the next vulnerability affects your stack