What’s Vulnerable › Vulnerabilities
CVE-2025-58360: OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-12-11
- EPSS: 61.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-611
Description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Affected products
- geoserver: before 2.25.6; from 2.26.0 before 2.26.2 — fixed in 2.25.6, 2.26.2
How to fix
Upgrade to a fixed version: geoserver 2.25.6, 2.26.2. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525
- https://osgeo-org.atlassian.net/browse/GEOS-11682
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360
Get alerted when CVE-2025-58360 or the next vulnerability affects your stack