What’s Vulnerable › Vulnerabilities
CVE-2025-58367: DeepDiff is vulnerable to DoS and Remote Code Execution via Delta class pollution
- Severity: critical (CVSS 10.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-10-18
- Weakness: CWE-915
Description
DeepDiff is a project focused on Deep Difference and search of any Python data. Versions 5.0.0 through 8.6.0 are vulnerable to class pollution via the Delta class constructor, and when combined with a gadget available in DeltaDiff, it can lead to Denial of Service and Remote Code Execution (via insecure Pickle deserialization) exploitation. The gadget available in DeepDiff allows `deepdiff.serialization.SAFE_TO_IMPORT` to be modified to allow dangerous classes such as posix.system, and then perform insecure Pickle deserialization via the Delta class. This potentially allows any Python code to be executed, given that the input to Delta is user-controlled. Depending on the application where DeepDiff is used, this can also lead to other vulnerabilities. This is fixed in version 8.6.1.
Affected products
- seperman deepdiff: from 5.0.0, < 8.6.1
References
- https://github.com/seperman/deepdiff/commit/c69c06c13f75e849c770ade3f556cd16209fd183
- https://github.com/seperman/deepdiff/releases/tag/8.6.1
- https://github.com/seperman/deepdiff/security/advisories/GHSA-mw26-5g2v-hqw3
Get alerted when CVE-2025-58367 or the next vulnerability affects your stack