What’s Vulnerable › Vulnerabilities
CVE-2025-58370: Roo Code: Potential Remote Code Execution via Bash Parameter Expansion and Indirect Reference
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-06-17
- Weakness: CWE-78
Description
Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Versions below 3.26.0 contain a vulnerability in the command parsing logic where the Bash parameter expansion and indirect reference were not handled correctly. If the agent was configured to auto-approve execution of certain commands, an attacker able to influence prompts could abuse this weakness to execute additional arbitrary commands alongside the intended one. This is fixed in version 3.26.0.
Affected products
- RooCodeInc Roo-Code: before 3.26.0 — fixed in 3.26.0
How to fix
Upgrade to a fixed version: RooCodeInc Roo-Code 3.26.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-58370 or the next vulnerability affects your stack