What’s Vulnerable › Vulnerabilities
CVE-2025-58371: Roo Code is vulnerable to command injection via GitHub actions workflow
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-09-30
- Weakness: CWE-78
Description
Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions 3.26.6 and below, a Github workflow used unsanitized pull request metadata in a privileged context, allowing an attacker to craft malicious input and achieve Remote Code Execution (RCE) on the Actions runner. The workflow runs with broad permissions and access to repository secrets. It is possible for an attacker to execute arbitrary commands on the runner, push or modify code in the repository, access secrets, and create malicious releases or packages, resulting in a complete compromise of the repository and its associated services. This is fixed in version 3.26.7.
Affected products
- RooCodeInc Roo-Code: before 3.26.7 — fixed in 3.26.7
How to fix
Upgrade to a fixed version: RooCodeInc Roo-Code 3.26.7. Check the vendor advisory for mitigations.
References
- https://github.com/RooCodeInc/Roo-Code/commit/a0384f35d5ae3b7f66506cc62dda25d9bb673f49
- https://github.com/RooCodeInc/Roo-Code/security/advisories/GHSA-xr6r-vj48-29f6
Get alerted when CVE-2025-58371 or the next vulnerability affects your stack