What’s Vulnerable › Vulnerabilities
CVE-2025-58374: Roo Code: Auto-approve allows npm install execution of malicious postinstall scripts
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-06 · updated 2026-06-17
- Weakness: CWE-78
Description
Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Versions 3.25.23 and below contain a default list of allowed commands that do not need manual approval if auto-approve is enabled, and npm install is included in that list. Because npm install executes lifecycle scripts, if a repository’s package.json file contains a malicious postinstall script, it would be executed automatically without user approval. This means that enabling auto-approved commands and opening a malicious repo could result in arbitrary code execution. This is fixed in version 3.26.0.
Affected products
- RooCodeInc Roo-Code: before 3.26.0 — fixed in 3.26.0
How to fix
Upgrade to a fixed version: RooCodeInc Roo-Code 3.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/RooCodeInc/Roo-Code/pull/7390/files
- https://github.com/RooCodeInc/Roo-Code/releases/tag/v3.26.0
- https://github.com/RooCodeInc/Roo-Code/security/advisories/GHSA-c292-qxq4-4p2v
Get alerted when CVE-2025-58374 or the next vulnerability affects your stack