What’s Vulnerable › Vulnerabilities
CVE-2025-58382: Privilege escalation in Brocade Fabric before 9.2.1c2 and 9.2.2 through 9.2.2a
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-305
Description
A vulnerability in the secure configuration of authentication and management services in Brocade Fabric OS before Fabric OS 9.2.1c2 could allow an authenticated, remote attacker with administrative credentials to execute arbitrary commands as root using “supportsave”, “seccertmgmt”, “configupload” command.
Affected products
- Brocade Fabric OS: before 9.2.1c2; from 9.2.2 before 9.2.2b — fixed in 9.2.1c2, 9.2.2b
How to fix
Upgrade to a fixed version: Brocade Fabric OS 9.2.1c2, 9.2.2b. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-58382 or the next vulnerability affects your stack