What’s Vulnerable › Vulnerabilities
CVE-2025-58386
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-06-17
- Weakness: CWE-285
Description
In Terminalfour 8 through 8.4.1.1, the userLevel parameter in the user management function is not subject to proper server-side authorization checks. A Power User can intercept and modify this parameter to assign the Administrator role to other existing lower-privileged accounts, or invite a new lower-privileged account and escalate its privileges. While manipulating this request, the Power User can also change the target account's password, effectively taking full control of it.
Affected products
- Terminalfour: from 8.0.0 before 8.4.1.2 — fixed in 8.4.1.2
How to fix
Upgrade to a fixed version: Terminalfour 8.4.1.2. Check the vendor advisory for mitigations.
References
- https://docs.terminalfour.com/release-notes/security-notices/cve-2025-58386/
- https://terminalfour.com
Get alerted when CVE-2025-58386 or the next vulnerability affects your stack