What’s Vulnerable › Vulnerabilities
CVE-2025-5842: Modern Design Library <= 1.1.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via class Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Modern Design Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘class’ parameter in all versions up to, and including, 1.1.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- butterflymedia Modern Design Library: before 1.1.5 — fixed in 1.1.5
How to fix
Upgrade to a fixed version: butterflymedia Modern Design Library 1.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/mdl-shortcodes/trunk/mdl-shortcodes.php#L197
- https://plugins.trac.wordpress.org/changeset/3317171/
- https://wordpress.org/plugins/mdl-shortcodes/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1be519d5-b505-4b5d-9f14-c8544e8f8298?source=cve
Get alerted when CVE-2025-5842 or the next vulnerability affects your stack