What’s Vulnerable › Vulnerabilities
CVE-2025-58434: Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 50.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-12 · updated 2026-09-30
- Weakness: CWE-306
Description
Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5 and earlier, the `forgot-password` endpoint in Flowise returns sensitive information including a valid password reset `tempToken` without authentication or verification. This enables any attacker to generate a reset token for arbitrary users and directly reset their password, leading to a complete account takeover (ATO). This vulnerability applies to both the cloud service (`cloud.flowiseai.com`) and self-hosted/local Flowise deployments that expose the same API. Commit 9e178d68873eb876073846433a596590d3d9c863 in version 3.0.6 secures password reset endpoints. Several recommended remediation steps are available. Do not return reset tokens or sensitive account details in API responses. Tokens must only be delivered securely via the registered email channel. Ensure `forgot-password` responds with a generic success message regardless of input, to avoid user enumeration. Require strong validation of the `tempToken` (e.g., single-use, short expiry, tied to request origin, validated against email delivery). Apply the same fixes to both cloud and self-hosted/local deployments. Log and monitor password reset requests for suspicious activity. Consider multi-factor verification for sensitive accounts.
Affected products
- FlowiseAI Flowise: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/commit/9e178d68873eb876073846433a596590d3d9c863
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-wgpv-6j63-x5ph
Get alerted when CVE-2025-58434 or the next vulnerability affects your stack