What’s Vulnerable › Vulnerabilities
CVE-2025-58437: Coder's privilege escalation vulnerability could lead to a cross workspace compromise
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-06 · updated 2026-10-19
- Weakness: CWE-277
Description
Coder allows organizations to provision remote development environments via Terraform. In versions 2.22.0 through 2.24.3, 2.25.0 and 2.25.1, Coder can be compromised through insecure session handling in prebuilt workspaces. Coder automatically generates a session token for a user when a workspace is started. It is automatically exposed via coder_workspace_owner.session_token. Prebuilt workspaces are initially owned by a built-in prebuilds system user. When a prebuilt workspace is claimed, a new session token is generated for the user that claimed the workspace, but the previous session token for the prebuilds user was not expired. Any Coder workspace templates that persist this automatically generated session token are potentially impacted. This is fixed in versions 2.24.4 and 2.25.2.
Affected products
- coder: from 2.22 before 2.24.4; from 2.25.0 before 2.25.2 — fixed in 2.24.4, 2.25.2
How to fix
Upgrade to a fixed version: coder 2.24.4, 2.25.2. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/commit/06cbb2890f453cd522bb2158a6549afa3419c276
- https://github.com/coder/coder/commit/20d67d7d7191a4fd5d36a61c6fc1e23ab59befc0
- https://github.com/coder/coder/commit/ec660907faa0b0eae20fa2ba58ce1733f5f4b35a
- https://github.com/coder/coder/pull/19667
- https://github.com/coder/coder/pull/19668
- https://github.com/coder/coder/pull/19669
- https://github.com/coder/coder/security/advisories/GHSA-j6xf-jwrj-v5qp
Get alerted when CVE-2025-58437 or the next vulnerability affects your stack