What’s Vulnerable › Vulnerabilities
CVE-2025-58439: ERP: Possibility of SQL injection due to missing validation
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-06 · updated 2026-06-17
- Weakness: CWE-89
Description
ERP is a free and open source Enterprise Resource Planning tool. In versions below 14.89.2 and 15.0.0 through 15.75.1, lack of validation of parameters left certain endpoints vulnerable to error-based SQL Injection. Some information like version could be retrieved. This issue is fixed in versions 14.89.2 and 15.76.0.
Affected products
- frappe erpnext: before 14.89.2; from 15.0.0 before 15.76.0 — fixed in 14.89.2, 15.76.0
How to fix
Upgrade to a fixed version: frappe erpnext 14.89.2, 15.76.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/erpnext/pull/49219
- https://github.com/frappe/erpnext/pull/49220
- https://github.com/frappe/erpnext/security/advisories/GHSA-fvjw-5w9q-6v39
Get alerted when CVE-2025-58439 or the next vulnerability affects your stack