What’s Vulnerable › Vulnerabilities
CVE-2025-58764: Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-10 · updated 2026-06-17
- Weakness: CWE-94
Description
Claude Code is an agentic coding tool. Due to an error in command parsing, versions prior to 1.0.105 were vulnerable to a bypass of the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.
Affected products
- anthropics claude-code: before 1.0.105 — fixed in 1.0.105
How to fix
Upgrade to a fixed version: anthropics claude-code 1.0.105. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-58764 or the next vulnerability affects your stack