What’s Vulnerable › Vulnerabilities
CVE-2025-58768: DeepChat's Mermaid rendering has XSS leading to RCE
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-09 · updated 2026-06-17
- Weakness: CWE-94
Description
DeepChat is a smart assistant uses artificial intelligence. Prior to version 0.3.5, in the Mermaid chart rendering component, there is a risky operation of directly using `innerHTML` to set user content. Therefore, any malicious content rendered via Mermaid will directly trigger the exploit chain, leading to command execution. This vulnerability is primarily caused by a failure to fully address the existing XSS issue in the project, leading to another exploit chain. The exploit chain is consistent with the report GHSA-hqr4-4gfc-5p2j, executing arbitrary JavaScript code via XSS and arbitrary commands via exposed IPC. Version 0.3.5 contains an updated fix.
Affected products
- ThinkInAIXYZ deepchat: before 0.3.5 — fixed in 0.3.5
How to fix
Upgrade to a fixed version: ThinkInAIXYZ deepchat 0.3.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-58768 or the next vulnerability affects your stack