What’s Vulnerable › Vulnerabilities
CVE-2025-58782: Apache Jackrabbit Core, Apache Jackrabbit JCR Commons: JNDI injection risk with JndiRepositoryFactory
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-08 · updated 2026-10-18
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache Jackrabbit Core and Apache Jackrabbit JCR Commons. This issue affects Apache Jackrabbit Core: from 1.0.0 through 2.22.1; Apache Jackrabbit JCR Commons: from 1.0.0 through 2.22.1. Deployments that accept JNDI URIs for JCR lookup from untrusted users allows them to inject malicious JNDI references, potentially leading to arbitrary code execution through deserialization of untrusted data. Users are recommended to upgrade to version 2.22.2. JCR lookup through JNDI has been disabled by default in 2.22.2. Users of this feature need to enable it explicitly and are adviced to review their use of JNDI URI for JCR lookup.
Affected products
- Apache Software Foundation Apache Jackrabbit: from 1.0.0 before 2.22.2 — fixed in 2.22.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Jackrabbit 2.22.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/t4wdrost6dh17dh406g792j9wq6xmy6v
- http://www.openwall.com/lists/oss-security/2025/09/06/3
Get alerted when CVE-2025-58782 or the next vulnerability affects your stack