What’s Vulnerable › Vulnerabilities
CVE-2025-59018: Information Disclosure in Workspaces Module
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-06-17
- Weakness: CWE-200
Description
Missing authorization checks in the Workspace Module of TYPO3 CMS versions 9.0.0‑9.5.54, 10.0.0‑10.4.53, 11.0.0‑11.5.47, 12.0.0‑12.4.36, and 13.0.0‑13.4.17 allow backend users to directly invoke the corresponding AJAX backend route to disclose sensitive information without having access.
Affected products
- typo3: from 9.0.0 before 9.5.55; from 10.0.0 before 10.4.54; from 11.0.0 before 11.5.48; from 12.0.0 before 12.4.37; from 13.0.0 before 13.4.18 — fixed in 10.4.54, 11.5.48, 12.4.37, 13.4.18, 9.5.55
How to fix
Upgrade to a fixed version: typo3 10.4.54, 11.5.48, 12.4.37, 13.4.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-59018 or the next vulnerability affects your stack